Updating connection failed nm ifupdown connection


19-Oct-2016 16:52

I have reached a point where I can connect to my server through the obfsproxy but then unable to connect to outside addresses, example unable to ping 8.8.8.8 ... No Reply: Message recipient disconnected from message bus without replying Sep 17 debian dbus[763]: [system] Activating via systemd: service name='org.freedesktop.nm_dispatcher' unit='dbus -org.freedesktop.nm-dispatcher.service'Sep 17 debian Network Manager[749]: Writing DNS information to /sbin/resolvconf Sep 17 debian dbus[763]: [system] Successfully activated service 'org.freedesktop.nm_dispatcher'Sep 17 debian systemd[1]: Started Network Manager Script Dispatcher Service.The connection will then disconnect after about a minute "Inactivity timeout", which is weird because "--inactive" is off by default, I also tried explicitly set "--inactive 0" but still it times out, presumably this won't be a problem when I am able to connect to external addresses. Destination Gateway Genmask Flags MSS Window irtt Iface0.0.0.0 A. C.254 0.0.0.0 UG 0 0 0 eth010.8.0.0 10.8.0.2 255.255.255.0 UG 0 0 0 tun010.8.0.2 0.0.0.0 255.255.255.255 UH 0 0 0 tun010.8.0.2 0.0.0.0 255.255.255.255 UH 0 0 0 tun1A. C.0 0.0.0.0 255.255.255.0 U 0 0 0 eth0Destination Gateway Genmask Flags MSS Window irtt Iface0.0.0.0 10.8.0.34 0.0.0.0 UG 0 0 0 tun00.0.0.0 172.31.8.1 0.0.0.0 UG 0 0 0 wlan010.8.0.1 10.8.0.34 255.255.255.255 UGH 0 0 0 tun010.8.0.33 0.0.0.0 255.255.255.255 UH 0 0 0 tun010.8.0.34 0.0.0.0 255.255.255.255 UH 0 0 0 tun0127.0.0.1 172.31.8.1 255.255.255.255 UGH 0 0 0 wlan0169.254.0.0 0.0.0.0 255.255.0.0 U 0 0 0 wlan ether ec:f4:bb:65:ea:ad txqueuelen 1000 (Ethernet) RX packets 0 bytes 0 (0.0 B) RX errors 0 dropped 0 overruns 0 frame 0 TX packets 0 bytes 0 (0.0 B) TX errors 0 dropped 0 overruns 0 carrier 0 collisions 0 device interrupt 20 memory 0xf7800000-f7820000 lo: flags=73 loop txqueuelen 0 (Local Loopback) RX packets 4297 bytes 501861 (490.0 Ki B) RX errors 0 dropped 0 overruns 0 frame 0 TX packets 4297 bytes 501861 (490.0 Ki B) TX errors 0 dropped 0 overruns 0 carrier 0 collisions 0tun0: flags=43 inet 10.8.0.33 netmask 255.255.255.255 destination 10.8.0.34 unspec 00-00-00-00-00-00-00-00-00-00-00-00-00-00-00-00 txqueuelen 100 (UNSPEC) RX packets 0 bytes 0 (0.0 B) RX errors 0 dropped 0 overruns 0 frame 0 TX packets 36 bytes 2649 (2.5 Ki B) TX errors 0 dropped 0 overruns 0 carrier 0 collisions 0wlan0: flags=4163 ether 3c:a9:f4:a7:da:8c txqueuelen 1000 (Ethernet) RX packets 28206 bytes 4168156 (3.9 Mi B) RX errors 0 dropped 0 overruns 0 frame 0 TX packets 4505 bytes 688565 (672.4 Ki B) TX errors 0 dropped 0 overruns 0 carrier 0 collisions 0port 1194proto tcpdev tunca /etc/openvpn/ca.crtcert /etc/openvpn/vpn.myask.crtkey /etc/openvpn/vpn.# This file should be kept secret dh /etc/openvpn/dh2048server 10.8.0.0 255.255.255.0 client-config-dir ccd push "redirect-gateway"keepalive 10 120tls-auth /etc/openvpn/0 # This file is secretcipher AES-128-CBC # AEScomp-lzouser nobodygroup nogrouppersist-keypersist-tuntls-timeout 60hand-window 120status /var/log/20log /var/log/openvpn.logverb 3#mute 3Thu Sep 17 2015 MULTI: multi_create_instance called Thu Sep 17 2015 Re-using SSL/TLS context Thu Sep 17 2015 LZO compression initialized Thu Sep 17 2015 Control Channel MTU parms [ L:1560 D:168 EF:68 EB:0 ET:0 EL:0 ]Thu Sep 17 2015 Data Channel MTU parms [ L:1560 D:1450 EF:60 EB:135 ET:0 EL:0 AF:3/1 ]Thu Sep 17 2015 Local Options hash (VER=V4): 'a642654b'Thu Sep 17 2015 Expected Remote Options hash (VER=V4): '0bdd0804'Thu Sep 17 2015 TCP connection established with [AF_INET]127.0.0.950Thu Sep 17 2015 TCPv4_SERVER link local: [undef] Thu Sep 17 2015 TCPv4_SERVER link remote [AF_INET]127.0.0.950Thu Sep 17 2015 127.0.0.950 TLS: Initial packet from [AF_INET]127.0.0.950, sid=ddf0950d 112234c3 Thu Sep 17 2015 127.0.0.950 VERIFY OK: depth=1, /CN=myask/name=myask Thu Sep 17 2015 127.0.0.950 VERIFY OK: depth=0, /CN=c8.myask Thu Sep 17 2015 127.0.0.950 Data Channel Encrypt: Cipher 'AES-128-CBC' initialized with 128 bit key Thu Sep 17 2015 127.0.0.950 Data Channel Encrypt: Using 160 bit message hash 'SHA1' for HMAC authentication Thu Sep 17 2015 127.0.0.950 Data Channel Decrypt: Cipher 'AES-128-CBC' initialized with 128 bit key Thu Sep 17 2015 127.0.0.950 Data Channel Decrypt: Using 160 bit message hash 'SHA1' for HMAC authentication Thu Sep 17 2015 127.0.0.950 Control Channel: TLSv1, cipher TLSv1/SSLv3 DHE-RSA-AES256-SHA, 2048 bit RSA Thu Sep 17 2015 127.0.0.950 [c8.myask] Peer Connection Initiated with [AF_INET]127.0.0.950 Thu Sep 17 2015 c8.myask/127.0.0.950 OPTIONS IMPORT: reading client specific options from: ccd/c8.myask Thu Sep 17 2015 c8.myask/127.0.0.950 MULTI: Learn: 10.8.0.33 - c8.myask/127.0.0.950Thu Sep 17 2015 c8.myask/127.0.0.950 MULTI: primary virtual IP for c8.myask/127.0.0.950: 10.8.0.33 Thu Sep 17 2015 c8.myask/127.0.0.950 PUSH: Received control message: 'PUSH_REQUEST' Thu Sep 17 2015 c8.myask/127.0.0.950 send_push_reply(): safe_cap=960Thu Sep 17 2015 c8.myask/127.0.0.950 SENT CONTROL [c8.myask]: 'PUSH_REPLY,redirect-gateway,route 10.8.0.1,topology net30,ping 10,ping-restart 120,dhcp-option DNS 8.8.8.8,dhcp-option DNS 8.8.4.4,ifconfig 10.8.0.33 10.8.0.34' (status=1) Thu Sep 17 2015 c8.myask/127.0.0.950 Connection reset, restarting [0] Thu Sep 17 2015 c8.myask/127.0.0.950 SIGUSR1[soft,connection-reset] received, client-instance restarting Thu Sep 17 2015 TCP/UDP: Closing socket VPN service 'openvpn' appeared; activating connections Sep 17 debian Network Manager[749]: (nm-openvpn-service:5007): nm-openvpn-WARNING **: Directory '/var/lib/openvpn/chroot' not usable for chroot by 'nm-openvpn', openvpn will not be chrooted. Sep 17 debian nm-dispatcher: Dispatching action 'vpn-up' for tun0Sep 17 debian Network Manager[749]: (tun0): Activation: successful, device activated.Hi, I am trying to setup my Open VPN client/server to use the obfsproxy and I have run into a few problems.The client/server setup has been working fine before trying the obfsproxy.

nm-openvpn[7156]: Initialization Sequence Completed nm-openvpn[7156]: event_wait : Interrupted system call (code=4) nm-openvpn[7156]: /sbin/ifconfig tun0 0.0.0.0 Network Manager[1485]: Policy set 'Auto elif' (wlan0) as default for IPv4 routing and DNS.

If someone can find a solution for this set up I would hugely appreciate it, as this problem is making my system unusable.